/
Databridge Events

Databridge Events

Overview

A key objective of the Call Journey platform is to deliver insights directly to customers as quickly and efficiently as possible. Databridge Events enables Call Journey to push specific insights (Topics) to your API in real-time, ensuring you receive analysis results the moment they are completed.

This provides two key benefits:

  • Immediate access to insights – No delays, enabling faster decision-making and response.

  • Seamless integration – Events are sent directly to an API of your choice, allowing you to incorporate the data into any part of your business workflow.

Terms

Term

Description

Term

Description

Destinations (aka Endpoints)

This is where the results of the analysis will be sent.

Events

This is a granular term that means something has happened. It’s a programmatic term indicating a change of state.

Topics

This is the ‘item’ that you are interested in getting a message about. We will continue to extend this list. Further details are below.

Authentication

This is how we will identify ourselves to your API. It’s how you know who we are.

Subscription

A Databridge Events subscription is like a subscription to a regular email. You will ‘subscribe’ to a topic that you are interested in. But unlike an email subscription, you’ll get it as soon as it happens. By using the Databridge Events service, you are creating a ‘subscription’.

How it works

Databridge Events is an event bus service that seamlessly integrates with your API, delivering insights as they are generated. This means you receive real-time updates, eliminating delays in accessing critical analysis.

With Databridge Events, you can subscribe to specific Topics that align with your interests, ensuring you only receive relevant insights.

All subscriptions must route to a single designated destination for consistency and streamlining data handling.

Topics

Root Cause

Root Cause provides information in the following sections:

  • Summary

  • Client Words

  • Intent

  • Dissatisfaction

  • Callback

Further details can be found here: Root Cause Event Schema 1.0

Authentication

The following options are available to provide a secure connection between Call Journey and your Destination endpoint.

Connection Option

Fields

Connection Option

Fields

  1. Basic

  • Username

  • Password

  1. OAuth Client Credentials

  • Authorization endpoint (https://example-domain.com/v1/*)

  • HTTP method (GET, POST, PUT)

  • Client ID

  • Client secret

  • [Optional] OAuth Http Parameters

    • OAuth Http Parameters are additional credentials used to sign the request to the authorization endpoint to exchange the OAuth Client information for an access token

  1. API Key

  • API key name

  • Key

Destination

Databridge Events can send to any API that supports the authentication methods. Common APIs are:

  • URL Endpoint (Custom API)

  • AWS SNS (Simple Notification Service)

  • AWS SQS (Simple Queue Service)

  • AWS API Gateway

Only one destination is supported, which means all ‘topic’ events must be sent to the same ‘destination’

Setup

Please contact your Call Journey account manager or contact us at support@calljourney.com

You will need to provide:

  • Destination details

  • Authentication type

  • Any rate limit per second on your API that we need to respect.

Do not email or send the Client Secret, Password or API Key.
Call Journey will provide a secure way to provide this information.

FAQ

Q1. What happens if your Destination endpoint is down

A1. Databridge Events will try for 24 hours and up to 185 times to deliver the message if it receives a 5xx or 429 HTTP status code. If, after this time, the endpoint remains down Databridge Events will be disabled.

Q2. How often is a message delivered

A1. The message will be delivered at least once

 

Related content

Copyright © VoiceAI Pty Ltd 2021, All Rights Reserved